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The tutorial below is designed for use with OpenSim version 4.0 and later. A version of the tutorial compatible with OpenSim version 3.3 is
available here .

I. Objectives
Purpose
The purpose of this tutorial is to demonstrate how musculoskeletal models can be used to study orthopaedic surgical techniques and to illustrate how
muscle moment arm, optimal muscle fiber length, and tendon slack length influence the variation of muscle force with respect to changes in joint angle. In
this tutorial, you will:
Become familiar with a wrist model and OpenSim's Property Editor
Simulate a tendon transfer surgery
Examine the effects of the surgery on joint moment, muscle force, and muscle moment arm
Investigate the effect of tendon slack length on isometric muscle force

Format
Each section of the tutorial guides you through certain tools within OpenSim's GUI and asks you to answer a few questions. The menu titles and option
names you must select and any commands you must type to run OpenSim will appear in bold face. The questions can be answered based on information
from OpenSim and basic knowledge of the human musculoskeletal system. As you complete each section of the tutorial, feel free to explore OpenSim and
the wrist model further on your own. Depending on the amount of exploration you do, this tutorial will take about 1-2 hours to complete.

II. Musculoskeletal Model of the Wrist
In this section, you will load a model of the human wrist [1] and examine its motions. You will then explore the wrist muscles and their functions.
Click the File menu and select Open Model.
Find the Models folder, which is located under your Documents folder on PC e.g., Documents\OpenSim\4.0\Models or your Documents folder on
Mac, e.g., Documents/OpenSim/4.0/Models. Note: When you first launch OpenSim, the default to install models and scripts files is your
Documents folders, you do have the choice to change the folder where you want to install these files.
Open the WristModel folder, select the file wrist.osim, and click Open.
Use the Coordinate sliders to investigate the wrist model. In particular, become familiar with wrist flexion and extension and radial and ulnar deviation. It
is important to understand the angle conventions to interpret the plots you will make later in the tutorial.
Note: Radial deviation is defined as wrist motion toward the radius bone, or thumb side. Wrist flexion is defined as wrist motion that faces the palm towards
the forearm, while wrist extension faces the palm away from the forearm.
In this OpenSim model, muscles are grouped based on their function.
In the Navigator, expand the Forces and Muscles headings. Use the buttons to the left of the Navigator (+ or -) to expand or collapse the
heading.
To hide all of the muscles in the model, right-click on the all muscle group heading, then choose Display > Hide.
To show the flexors muscle group, right-click on the flexors heading, then choose Display > Show. Now the only muscles displayed should be
the wrist flexors. To hide the wrist flexors, right-click on the flexors heading again and select Display > Hide. You can see which muscles are in
the flexors group by expanding the list.
Repeat the same steps to display the extensors, radial deviators, and ulnar deviators muscle groups individually.

Questions
1. Which motion is expressed in positive angles: wrist flexion or wrist extension?
2. Which motion is expressed in positive angles: radial deviation or ulnar deviation?
3. What are the functions of the Extensor Carpi Ulnaris (ECU) muscle? Check or circle all that apply.
wrist extension wrist flexion radial deviation ulnar deviation hip extension
4. What are the functions of the Extensor Carpi Radialis Brevis (ECRB)? Check or circle all that apply.
wrist extension wrist flexion radial deviation ulnar deviation hip extension

III. Simulation of a Tendon Transfer
Spinal cord injury at the level of the cervical spine causes a loss of hand function. In some patients, the ability to grasp and release objects may be
restored through electrical stimulation of paralyzed muscles, called functional electrical stimulation (FES). However, FES is only feasible in those muscles
where the connection between the nervous system and the muscle remains intact within the muscle. In many cases, the muscles that perform the desired
functions (e.g., finger flexion, thumb abduction) have been damaged too greatly to respond to FES. In addition, there is often a loss of balance at the wrist
joint, causing the wrist to remain in a flexed and ulnarly deviated position [2]. In these situations, tendon transfers are performed to i) alter the paths of
muscles that do respond to FES to locations where they can enhance hand function, and ii) restore a more functional configuration of the wrist joint so that
grasp and release tasks can be accomplished.
In this section of the tutorial, you will transfer the ECU tendon to the ECRB tendon and evaluate the mechanism by which this tendon transfer restores
balance to the wrist.
Display the transfer muscle group only by right-clicking its heading and selecting Display > Show Only. The ECU_pre-surgery and the ECRB m
uscle paths should now be visible on the model.
Note: ECU_pre-surgery represents the ECU muscle before the simulated tendon transfer surgery.
Expand the transfer muscle group and identify each muscle by using Display > Show Only on each.
To simulate the surgery, you will edit the paths of the muscles in the visualizer window. Each end of a muscle-tendon complex connects to bone. In this
model, the most proximal connection is the origin, and the most distal connection is the insertion point. You will first select the insertion point of the ECU_pr
e-surgery muscle and move its location. Then you will perform a similar operation for the two via points proximal to it. All muscle via points are graphically
represented as small red spheres on the muscle path, and coincide with the "kinks" in the muscle path.
Before editing the model, go to the File menu select Save Model As... Save the current model as wrist_TendonSurgery.osim.
Once you have done this, right-click on the Wrist_Model name in the OpenSim Navigator window and select "Rename..." Rename the model to
"Wrist_Model_Tendon_Surgery."
To return the model to its default pose, click Poses > Default in the Coordinates window.
To view muscle properties, click on the ECU_pre-surgery muscle name in the Navigator. The muscle parameters will appear in the window
below the Navigator.
Note: If the Properties Window is not open, you can open it by going to Window > Properties in the main menu bar on top of the OpenSim window.
Before starting the simulated surgery, make sure you can see both muscles from the transfer muscle group. Then, zoom in on the wrist joint. Click
on the insertion muscle point of ECU_pre-surgery.
Note: Once selected, a yellow box will appear around the muscle point. Its name (ECU_pre-surgery-P7) should be displayed at the bottom-left of
the GUI
To move the selected muscle point, use the red, blue, and green arrows that appear on muscle selection to adjust the muscle point's location
along a single axis.

Repeat this process for the two remaining, proximal muscle points of the ECU: ECU_pre-surgery-P6 and ECU_pre-surgery-P5.
Your goal is to align the ECU_pre-surgery path with the ECRB path, as shown to the right. Note: in the image below, we have increased the size
of the muscle path points to improve their visibility.

IV. Biomechanical Effects of Tendon Transfer
To analyze the effects of the surgery, you need a model of the ECU muscle both before and after surgery. Although you did a great job moving the muscle
points, a muscle with a path similar to the transfer you just completed has already been built into the model.
To close the current model you just edited, right-click on the model in the Navigation window and select Close. Alternatively, you can click the File
menu and select Close Model.
Open the original, unedited wrist.osim model by clicking File > Open Model, and opening wrist.osim.
Expand the Forces and Muscles group. Open the all muscle group, right-click on the muscle titled ECU_post-surgery, and select Display >
Show Only. A muscle path similar to the transfer you completed should appear in the model.
Note: ECU_post-surgery represents the ECU muscle after the simulated tendon transfer surgery.

Ensure no muscle points are selected and the model is in the neutral (default) configuration.
Note: You can return the model to its default configuration by selecting Poses > Default in the Coordinates tab.

Now you will investigate the effect of the transfer on wrist extensor strength by creating plots of the maximum isometric wrist moments before and after the
simulated surgery. To see how the surgery will affect wrist extension strength, you will examine maximum isometric wrist extension moments (i.e., the
moments generated when all the extensor muscles are maximally excited).
Note: Isometric moments assume zero muscle velocity.
Open a new plot from the Tools menu. Click the Properties button and type Wrist Flexion Moment vs. Flexion Angle into the Textbox under
the Title tab. Click OK. Click the Y-Quantity button, and select moment > flexion.
Note: Do not select elbow_flexion!
Filter the muscle list by model and extensors group. Select all of the muscles in the extensors group by checking the select all shown checkbox.
De-select the ECU_post-surgery muscle by "un-checking" the ECU_post-surgery checkbox. To plot the sum of all the moments, check the sum
only checkbox.
Click the X-Quantity button and select flexion.
Edit the Curve Name text to read Before Surgery.
Then click Add.

A curve labeled "Before Transfer" should appear on the plot, which is the sum of the isometric moments generated by all of the wrist extensors before the
surgery. Now you will add another curve to compare the strength of the extensors after the transfer.
In the muscle selection window, de-select ECU_pre-surgery and select ECU_post-surgery.
Note: Ensure the sum only checkbox is still selected and keep the muscle selection window open.
Add a Curve named After Surgery.
Note: To print or save a plot, right-click on the plot and select Print or Export Image.

Now let's examine the effects of the transfer on the deviation strength of the wrist muscles.
Start a new plot, edit the plot title to read Wrist Deviation Moment vs. Deviation Angle.
Click Y-Quantity and select moment > deviation.
Filter the ulnar deviators group and click the select all shown check box.
De-select the ECU_post-surgery muscle
Note: Ensure the sum only checkbox is still selected and keep the muscle selection window open.
Click X-Quantity and select deviation, edit the Curve Name to be Before Surgery, and click Add.
Repeat the above steps, replace the ECU_pre-surgery muscle with the ECU_post-surgery muscle. Add the Curve named After Surgery.

Questions
5. In these plots, given how the model defines the wrist flexion degree of freedom, is wrist extension moment denoted by positive or negative values?
6. What happens to the maximum moment of the wrist extensors if the ECU muscle is transferred to the ECRB?

Hint: Remember, one of the goals of the surgery is to increase wrist extension strength.
7. In these plots, is the sign of an ulnar deviation moment positive or negative?
8. What happens to the maximum moment of the ulnar deviators if the ECU muscle is transferred to the ECRB location?
9. One goal of this tendon transfer surgery is to decrease excessive ulnar deviation. Has your simulated surgery achieved this goal? Why or why not?

After answering these questions, close the plotter window.
You are now going to take a more in-depth look at the effects of the tendon transfer on the function of the ECU muscle.
Open a new plot, and click Y-Quantity and select moment > flexion.
Click the Muscles button and select ECU_pre-surgery and ECU_post-surgery from the list.
Click X-Quantity and select flexion.
Edit the plot title to read Wrist Moment vs. Flexion Angle, and then click Add.

Hover the cursor over a curve on the plot to see a tool tip that gives the coordinates of that particular point on the curve.

Questions

10. What is the peak value of the ECU extension moment before transfer? At what flexion angle does it occur?
Note: Remember, extension moments are negative on the plots.
11. What is the peak value of the ECU extension moment after transfer? At what flexion angle does it occur?
12. Does the moment-generating capacity of the ECU vary more with flexion angle before or after the simulated surgery?

Investigate the differences in wrist strength further by creating plots of 1) flexion moment vs. flexion, 2) tendon force vs. flexion, and 3) flexion
moment arm vs. flexion for the ECU_pre-surgery and ECU_post-surgery muscles. Note: You can open multiple plotter windows simultaneously. When
finished, you should have created three plots (flexion moment, tendon force, moment arm) in three separate plotter windows with two curves each.

Questions
13. Write down the peak values of each curve (flexion moment, tendon force, moment arm), the joint angle at which the peak occurs, and describe the
general shapes of the curves.

OpenSim's Property Editor allows you to examine and edit the muscle parameters used to estimate the force-length curve of this muscle.
To view the properties of a muscle, click on the muscle name in the Navigator. The muscle parameters are visible below the Navigator in the Pro
perties window.

Questions
14. What is the optimal fiber length of the ECU_pre-surgery muscle?
15. What is the optimal fiber length of ECU_post-surgery?
16. Calculate the ratio of optimal fiber length to peak moment arm for ECU_pre-surgery and ECU_post-surgery.
17. Explain the differences in the isometric moment vs. wrist flexion angle plots for the ECU_pre-surgery and ECU_post-surgery muscles, based on the
plots of force and moment arm and the ratio of optimal fiber length to peak moment arm.
18. Specifically, what does the difference between the ratios of optimal fiber length to moment arm for the ECU before and after the tendon transfer tell
you?
After answering these questions, close all of the plotter windows.

V. The Effect of Tendon Slack Length on the Isometric Force-Angle Curve
The previous simulation illustrated how the moment arm and optimal fiber length of a muscle influence its isometric strength and the portion of the forceangle curve over which the muscle operates. Another factor in determining the isometric force vs. joint angle relationship is tendon slack length. Tendon
slack length is the length at which the tendon begins to generate force.
Make three new plots in three separate plotter windows for the ECRB muscle: tendon force vs. flexion, muscle-tendon length vs. flexion, fiber
length vs. flexion.
Note: You

can open multiple plotter windows simultaneously. Do not close any of the plots.

Click on ECRB in the Navigator and examine its properties in the Properties Window.

Questions
19. What is the tendon slack length of the ECRB muscle?
20. What is the optimal fiber length of the ECRB muscle?

Now you will examine the effect of changing muscle parameters.
Edit the tendon_slack_length text box to read 0.2105 in the Properties Window.
To add new curves for the edited ECRB muscle, click Add in each plotter window.

Note: It may be helpful to edit each Curves Name to read "ECRB lts = 0.2105 m" before adding the curves.
Questions

21. How did changing the tendon slack length of the ECRB alter the tendon force vs. flexion angle curve?
22. How did changing the tendon slack length of the ECRB alter muscle-tendon length vs. flexion angle curve?
23. How did changing the tendon slack length of the ECRB alter the fiber length vs. flexion curve?
24. At what flexion angles do the fiber lengths of the ECRB and the edited ECRB reach the optimal fiber length? Compare these angles with the peaks of
the force vs. flexion plots.
25. Explain the effect of tendon slack length on the force-angle relationship of a muscle based on what you have learned about its effect on fiber length
and muscle-tendon length.
Feel free to change the tendon slack length and make more curves to further demonstrate the effects you have seen. For additional information, refer to
the references below.

Credits
Wendy Murray and Scott Delp with help from many others.
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