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Simulation and Analysis of a Tendon Transfer Surgery 

This document and tutorial is a modified version of the online OpenSim tutorial 2 and aims to replicate 

the findings from the paper by Delp, Ringwelski and Carroll (1994) Transfer of the rectus femoris: 

effects of transfer site on moment arms about the knee and hip. J Biomechanics, 27 (10), 1201-1211. 

The tutorial was created by Hans Kainz for the ESMAC 2022 seminar. Liesel De Block and Lissa Aerts 

helped creating this tutorial during their internship at the University of Vienna. 

I. Objectives 

Background  

Decreased knee flexion during the swing phase of gait might by caused by over-activity of the 

rectus femoris muscle in some patients with stroke or cerebral palsy. Limited knee range of motion 

is often treated by surgically releasing the rectus femoris from the patella and transferring it to one 

of four sites: semitendinosus, gracilis, sartorius, or the iliotibital tract. The aim of the study by Delp, 

Ringwelski and Carroll (1994) was to determine if there are differences between these four tendon 

transfer sites in terms of post-surgical moment arms about the knee and hip joint. 

Purpose 

The purpose of this tutorial is to demonstrate how musculoskeletal models can be used to study 

orthopedic surgical techniques and to illustrate how muscle moment arms are affected by a muscle-

tendon transfer surgery. In this tutorial, you will: 

• Become familiar with the gait2392_simbody_RF_surgery_tutorial.osim model and OpenSim’s 

Property Editor 

• Simulate a tendon transfer surgery 

• Examine the effects of the surgery on knee and hip moments arms 

• Use OpenSim to approach an important clinical problem 

Format 

Each section of the tutorial guides you through certain tools within OpenSim's GUI and asks you to 

answer a few questions. The menu titles and option names you must select and any commands you 

must type to run OpenSim will appear in bold font. The questions can be answered based on 

information from OpenSim and basic knowledge of the human musculoskeletal system. As you 

complete each section of the tutorial, feel free to explore OpenSim and the 

gait2392_simbody_RF_surgery_tutorial.osim further on your own.  

https://simtk-confluence.stanford.edu:8443/display/OpenSim/Tutorial+2+-+Simulation+and+Analysis+of+a+Tendon+Transfer+Surgery
https://neuromechanics.univie.ac.at/team/
https://www.esmac2022.org/pre-conference-seminars/
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II. Musculoskeletal Model  

 
In this section you will load a model of the human body and examine its motions. You will then 

explore four different muscle transfer sites (semitendinosus, gracilis, sartorius, or the iliotibial tract) 

and its muscle functions.  
 

• Click the File menu and select Open Model. 

• Select the gait2392_simbody_RF_surgery_tutorial.osim, and click Open.  

Use the Coordinate sliders to investigate the model. In particular, become familiar with knee 

flexion and extension, hip flexion and extension and hip internal and external rotation. It is 

important to understand the angle conventions to interpret the plots you will make later in the 

tutorial.  

In this OpenSim model, muscles are grouped based on their function. 

• In the Navigator, expand the Forces and Muscles headings. Use the buttons to the left of the 

Navigator (+ or -) to expand or collapse the heading.  

• To hide all of the muscles in the model, right-click on the all muscle group heading, then 

choose Display > Hide.  

• To show the knee flexors group, right-click on the R_knee_bend heading, then choose 

Display > Show. Now the only muscles displayed should be the knee flexors. To hide the 

knee flexors, right-click on the R_knee_bend heading again and select Display > Hide. You 

can see which muscles are in the knee flexors group by expanding the list.  

• Repeat the same steps to display the R_knee_ext, R_hip_flex, R_hip_ext, R_hip_inrot and 

R_hip_exrot muscle groups individually.  

Note: You can go to the Coordinates window to change the values of the coordinates. 

Questions 

1. Which motion is expressed in the positive angles: knee flexion or knee extension? 

2. Which motion is expressed in the positive angles: hip internal or external rotation? 

3. What are the functions of the rectus femoris (rect_fem) muscle? Check or circle all that 

apply. 

○ hip flexion ○ hip extension ○ knee flexion ○ knee extension ○ hip abduction ○ hip 

adduction 

4. What are the functions of the sartorius (sar) muscle? Check or circle all that apply.  

○ hip flexion ○ hip extension ○ knee flexion ○ knee extension ○ hip abduction ○ hip 

adduction 

5. What are the functions of the semitendinosus (semiten) muscle? Check or circle all that 

apply.  

○ hip flexion ○ hip extension ○ knee flexion ○ knee extension ○ hip abduction ○ hip 

adduction 

6. What are the functions of the gracillis (grac) muscle? Check or circle all that apply.  

○ hip flexion ○ hip extension ○ knee flexion ○ knee extension ○ hip abduction ○ hip 

adduction 
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III. Simulation of a tendon transfer 

From the paper from Delp, Ringwelski and Carroll (1994): 

Excessive knee flexion during the stance phase is one of the most common abnormalities found in 

people with spastic cerebral palsy (crouch gait). The hamstrings can be lengthened to improve knee 

extension and reduce excessive knee flexion during the stance phase (Gage et al., 1987; Ray & Ehrlich, 

1979; Thometz et al., 1989). However, a common complication of isolated hamstring lengthening is 

decreased postoperative knee flexion during the swing phase (Baumann et al., 1980), which is often 

caused by an over-active rectus femoris (Gage et al., 1987; Perry, 1987). The rectus femoris is generally 

only engaged at the start of the swing phase because it provides a flexion and extension moment 

around the hip and knee. However, in some patients with spastic cerebral palsy, the rectus femoris 

has prolonged or continuous activity during the swing phase which restricts knee flexion (Perry, 1987; 

Sutherland, 1990; Waters, 1979). Transfer of the rectus femoris tendon in conjunction with hamstring 

lengthening has been proposed to avoid decreased knee flexion after surgery (Perry, 1987).  

Delp and his colleagues used musculoskeletal modelling and cadaver experiments to assess 

differences in knee and hip moment arms after different variants of a rectus femoris transfer surgery, 

(Delp et al., 1994). In this tutorial, we aim to replicate the musculoskeletal modelling part of their 

study. We will perform virtual surgeries by releasing the rectus femoris from the patella and 

transferring it to one of four sites: semitendinosus, gracilis, sartorius, or the iliotibial tract. We will then 

determine if there are any differences between these four tendon transfer sites in terms of post-

surgical moment arms about the knee and hip.   

In this section of the tutorial, you will transfer the rectus femoris tendon to the four tendon transfer 

sites and evaluate the mechanism by which these tendon transfers affect knee and hip moment 

arms.  

 

• Display the Transfer muscle group only by right-clicking its heading and selecting Display 

> Show Only.  

• Identify each muscle by using Display > Show Only on each. The rect_fem_r_to_GRA, 

rect_fem_r_to_SAR, rect_fem_r_to_ST, rect_fem_r_to_IT, grac_r, sar_r, semiten_r and tfl_r muscles 

paths should now be visible on the model. 

Note: rect_fem_r_to_GRA, rect_fem_r_to_SAR, rect_fem_r_to_ST, rect_fem_r_to_IT all represent 

the rectus femoris muscle before the simulated tendon transfer surgeries. Hence, all these 

muscles are identical. 

 

To simulate the surgery, you will edit the paths of the muscles (rect_fem_r(to_GRA, to_SAR, to_ST, 

to_IT))in the visualizer window. Each end of a muscle-tendon complex connects to a bone. In this 

model, the most proximal connection is the origin, and the most distal connection is the insertion 

point. You will first select the insertion point of the rectus femoris (rect_fem_r_to_ST) muscle and 

move its location to the first tendon transfer site: semitendinosus (semiten_r). Then you will 

perform a similar operation for the other transfer sites: gracilis (grac_r), sartorius (sar_r), and 

iliotibial tract (tfl_r). All muscle via points are graphically represented as small red spheres on the 

muscle path, and coincide with the “kinks” in the muscle path.  
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• Before editing the model, go to the File menu and select Save Model As… . Save the current 

model as RectusFemoris_TendonSurgery.osim. 

• Once you have done this, right-click on the 

3DGaitModel2392TendonTransferRectusFemoris name in the OpenSim Navigator 

Window and select “Rename…” . Rename the model to 

“RectusFemoris_Model_TendonSurgery”.  

• To return the model to its default pose, click Poses > Default in the Coordinates Window.  

• To view muscle properties, click on rect_fem_r in the Navigator. The muscle parameters will 

appear in the window below the Navigator. 

Note: If the Properties Window is not open, you can open it by going to Window > Properties in 

the main menu bar on top of the OpenSim window.  

• Before starting the simulated surgery, make sure you can see the muscles from the Transfer 

muscle groups. Then, zoom in on the knee joint. Visualize only the matching muscles (for 

example: rect_fem_r_to_ST and semiten_r). Click the insertion muscle point of the 

rect_fem_r_to_ST and move it to the insertion of the semiten_r muscle. Note: Once selected, a 

yellow box will appear around the muscle points. Its name (MovingPathPoint: rect_fem_r-P1, 

rect_fem_r-P2_0, and rect_fem_r-P3) should be displayed at the bottom-left of the GUI.  

• To move the selected muscle points, use the red, blue, and green arrows that appear on 

muscle selection to adjust the muscle point’s location along a single axis. 

 

 

 

• Your goal is to align the rect_fem_r_to_ST path with the semiten_r path.  

• Repeat this process for the three remaining transfer sites: gracilis, sartorius, and iliotibial tract 

(grac_r, sar_r, tfl_r). 

Note: We use the TFL muscle to approximate the location of the iliotibial tract.  
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IV. Biomechanical Effects of Tendon Transfer 

To analyze the effects of the surgery, you need a model of the Rectus Femoris muscle both before 

and after surgery. Although you did a great job moving the muscle points, a muscle path like the 

transfer you just completed has already been added to the model.  

 

• To close the current model, you just edited, right-click on the model in the Navigation 

window and select Close. Alternatively, you can click the File menu and select Close Model.  

• Open the original, unedited gait2392_simbody_RF_surgery_tutorial.osim model by clicking File 

> Open Model, and opening gait2392_simbody_RF_surgery_tutorial.osim.  

• Expand the Forces and Muscles group. Open the RF_post-surgery group, by right-

clicking its heading and selecting Display > Show Only. The muscle paths similar to the 

transfer you completed should appear in the model. Note: RF_toSTsurgery, RF_toGRAsurgery, 

RF_toSARsurgery and RF_toITsurgery represent the rectus femoris muscle after the simulated 

tendon transfer surgery to the semitendinosus, gracilis, sartorius muscle and iliotibial tract, 

respectively.  

• Ensure no muscle points are selected and the model is in the neutral (default) configuration. 

Note: you can return the model to its default configuration by selecting Poses > Default in the 

Coordinates tab.  

Now you will investigate the effect of the transfer on knee flexion moment arm by creating plots 

of the (peak) knee flexion moment arms after transfer to semitendinosus, gracilis, sartorius, and 

ilitiobial tract. To see how the surgeries affected knee flexion moment arms, you will examine 

peak knee flexion moment arms (i.e., the maximal perpendicular distance to the joint centre).  

• Open a new plot from the Tools menu. Click the Properties button and type knee flexion 

moment arm vs knee flexion angle into the Textbox under the Title tab. Click OK. Click the 

Y-quantity button, and select moment arm > knee_angle_r.  

• Filter the muscles list by model and R_knee_ext or R_hip_flex group. Select the following 

muscle: rect_fem_r.  

• Click the X-Quantity button and select knee_angle_r. 

• Edit the Curve Name text to read Before Surgery. 

• Then click Add. 

A curve labeled "Before Transfer" should appear on the plot, which is the knee flexion moment 

arm of the rectus femoris before the tendon transfer. 

Now you will add four curves to compare the knee flexion moment arm between the transfer to 

the four different sites. 

• In the muscle selection window, deselect rect_fem_r and select the RF_post_surgery group 

(RF_toGRAsurgery, RF_toSTsurgery, RF_toSARsurgery and RF_toITsurgery). Then click Add. 

Now let's examine the effects of the four transfers on the knee flexion moment arms of the rectus 

femoris muscle. 
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Questions 

7. In these plots, given how the model defines the knee flexion degree of freedom, is knee 

extension angle denoted by positive or negative values?  

8. What happens to the maximum knee flexion moment arm of the rectus femoris muscle if 

this muscle is transferred to the gracilis site?  

9. Which muscle site has the highest knee flexion moment arm: the gracilis site, the sartorius 

site, the semitendinosus site or the iliotibial tract?  

10. One goal of this tendon transfer surgery is to increase knee flexion. Have all the simulated 

surgeries achieved this goal?  

11. Are our results in agreement with the findings from by Delp, Ringwelski and Carroll (1994)? 

12. Do you think our model or analysis include limitations? 
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