
Simulation-Based Design to Prevent Ankle 

Injuries 

All example files are included in the Model folder "ToyDropLandingModel" included with the 

OpenSim installation. 

Overview 

The purpose of this exercise is to use OpenSim to evaluate the risk of injury during landing and 

to design assistive devices to prevent injuries. You will examine how a passive ankle–foot 

orthosis (AFO), muscle reflexes, and muscle co-activation affect ankle inversion injury risk. In a 

short amount of time, you should be comfortable running forward dynamic simulations with 

varying conditions (such as orthosis stiffness) and plotting the results to compare their effects. 

I. Explore the musculoskeletal model 

II. Evaluate ankle inversion injury during a drop landing on a sloped surface 

III. Analyze the effects of an ankle–foot orthosis (AFO) on ankle inversion 

IV. Advanced Design Challenge: Create an active orthotic 

V. Analyze the effects of muscle co-activation 

VI. Explore: Prevent injury with a device and training program 

Note that the musculoskeletal model and controller used in this example are simplified for 

demonstration purposes. A more comprehensive musculoskeletal model would be needed to 

perform research. For example, the controller is a simplified (toy) version of the stretch reflex 

generated by muscle spindles that detect lengthening of muscle fibers. The toy reflex controller 

responds to whole muscle–tendon lengthening speed and is not isolated to lengthening speed of 

the muscle fiber. Additionally, there is no transmission delay between stretch detection and 

eliciting a muscle excitation, and the model does not include all the passive structures (e.g., 

ligaments) that resist motion of the ankle joint. 

Introductory Slides 

I. Explore the musculoskeletal model 

A. Launch OpenSim 

You can launch OpenSim 3.2 from the Windows Start Screen (pre Windows 8, use the start 

menu). If you used default installation settings, simply select Start Screen (Windows Key) and 

type OpenSim. You will see multiple information panels and an empty main view. 

 



B. Explore the model 

1. In your favorite file browser, navigate to the folder where you installed OpenSim (e.g. 

C:\OpenSim 3.1), then find the folder Models\ToyDropLanding.  

2. Copy the ToyDropLanding folder to a location of your choice. This well let you play 

with the models without fear of corrupting the example for future reference. From now 

on, we will refer to this location as [Example_Dir]\ToyDropLanding  

3. In the OpenSim GUI, select File>Open Model.... 

4. Select ToyLandingModel.osim. 

The OpenSim GUI will now show a view window containing a model with a skeleton and a 

platform. 

 The skeleton consists of a torso, a pelvis, and two legs with a total of 23 degrees of 

freedom and 70 muscle–tendon actuators. 

 We can explore various components of the model using the Navigator panel. Expand the 

model by clicking the "+" icon next to the model's name. You should see groups 

including Bodies and Joints. 

 Motion between the tibia and foot is described by two joints. Expanding the Joints group 

will reveal all joints in the model. Find the joints associated with the ankle of the right 

leg: ankle_r and subtalar_r. These represent the talocrural (or "true ankle") joint and the 

subtalar joint. 

 Contact spheres are attached to the feet to produce foot–floor contact forces (see the 

Forces>Contact Forces group in the Navigator panel). 

C. Explore the model's joint coordinates 

The floor is modeled as a contact plane with four degrees of freedom. The model is posed so it will 

land on its right leg upon contact with the platform. The left hip and knee joints are locked to hold the pose and 

avoid interference from the left leg during landing. You can explore these degrees of freedom using the 

Coordinates panel: 

1. Select the Coordinates tab in the left panel. 

2. Use the sliders to change the ankle_angle_r and subtalar_angle_r coordinates. Zoom 

in on the ankle joint. Click and drag with the right mouse button to zoom in and out. Use 

the middle mouse button to translate and the left mouse button to rotate the view.  

3. Unlock the platform_rx coordinate (by clicking on the lock icon). 

4. Enter values in the platform_rx text field or move the slider to change the angle of the 

platform in the frontal plane. You can use the platform_ry and platform_rz coordinates 

to rotate the platform around its other two (orthogonal) axes. 

5. Unlock platform_ty and change its value to move the platform up and down. 

6. Select Poses>Default from the Coordinates panel to return the model to its original 

pose. 

7. Lock all the platform coordinates. 

Questions 



1. Which degrees of freedom enable ankle inversion/eversion? 

2. To tilt the platform in the sagittal plane (i.e. about the axis perpendicular to the sagittal 

plane), would you change platform_ry or platform_rz? 

3. Why do you think the mtp_angle_r coordinate in the model is locked? 

II. Evaluate ankle inversion injury during a drop landing on 

a sloped surface 

A. Simulate a drop landing 

1. Verify that the model is in its Default pose, with platform_rx set to 20 

degrees, platform_ry to 0 degrees, platform_rz to 0 degrees, and platform_ty to -0.5 

meters. All four platform coordinates should be locked. This will prevent the platform 

from falling or rotating on impact.  

2. Find the Simulate button (Green Runner) in the OpenSim Toolbar. 

3. Click the arrow next to the simulate button, and select the End Time... drop down item. 

4. In the popup dialogue, set the simulation time to 0.4 seconds.  From now on, OpenSim will remember this 

choice when you hit the Simulate button and run a forward simulation for 0.4 seconds. 
5. Click the Simulate button to simulate for 0.4 seconds. OpenSim will use the current pose 

of the model in the GUI as the starting state for the simulation. The model will animate 

during the forward simulation.  

6. Once the simulation has completed, you can use the animation controls above the view 

window to play, pause, and scroll through the resulting motion and muscle 

activity. Zoom in on the ankle joint and replay the motion.  

7. Click on the Navigator panel and find the Motions list. The motion Results in bold 

corresponds to the simulation you just generated.  

8. Right click the bold "Results" motion and Rename... it to "Unassisted".   

9. To save the results, right click the "Unassisted" motion and select Save As (e.g 

Results_Unassisted.sto). 

B. Plot and analyze the simulation results 

1. Open a new plot window by selecting Tools>Plot.... 

2. Click the Y-Quantity... button and select Unassisted(Deg.)... near the bottom of the list 

to select kinematic data from your last simulation. If you saved the motion to a file, you 

can also use the Load file... option and navigate to the desired results file. 

3. In the Filter by pattern text box, type "sub" to filter the results to just those containing 

the text string "sub". 

4. Select subtalar_angle_r and click OK. 

5. Select X-Quantity>time to choose time as the independent variable. 

6. Click Add to display the data as a curve. 

7. Click on "Figure 1" in the Curves List to highlight it. Click again to rename. Modify the 

title field (e.g., "Ankle inversion (subtalar angle) during drop landing"). Alternatively, 

right click and edit using in the Properties menu 



8. Click on "subtalar_angle_r" to highlight the curve label in the Curves List box and 

click again to rename. Since this simulation used a model with no assistive devices, 

change this curve name to "Unassisted". 

9. Answer the questions below, then minimize the plot window. Keep the plot window 

open so you can use it to compare these results to simulations with an AFO. 

Questions 

1. What is the maximum subtalar angle during the drop landing? 

2. Would an ankle inversion injury have occurred during this landing? According to 

previous research (Siegler et al., 1990; Lapointe et al., 1997), angles larger than 25 

degrees may cause injury. 

III. Analyze the effects of an ankle–foot orthosis (AFO) on 

ankle inversion 

You will now repeat Part II using a model with a two-segment passive ankle foot orthosis 

(AFO): 

 The AFO has a footplate that is rigidly attached to the foot and a cuff that is rigidly 

attached to the tibia. 

 The footplate and cuff are connected at two hinge points by six dimensional springs, 

called bushings. Pink markers identify the connection points. The bushings resist the 

relative translation and rotation of the footplate and cuff. 

A. Explore the AFO model 

1. Select File>Open Model... and select ToyLandingModel_AFO.osim. Once the model 

loads, you will see a similar drop-landing model, but with an ankle–foot orthosis (AFO) 

attached to the right foot. The model will also appear in the Navigator panel. It's name is 

in bold, indicating it is the current model. 

2. Explore the model using the Navigator panel. Which new bodies and joints define the 

AFO we've added? 

3. Find the Property Editor to see more details about these new components. If you don't 

see the Property Editor in the bottom-left corner of your screen, select Properties from 

the Window menu to display it.  

B. Simulate and analyze a drop landing with a "soft" AFO 

Simulate the drop landing with the default "soft" AFO: 

1. Repeat the simulation steps from Part II.A above. The Simulate button acts on the current 

model, shown in bold in the Navigator panel. This should be the ToyLandingModel_AFO 

that you just loaded. Rename and the new results as "SoftAFO" this time and save as 

"Results_SoftAFO". 



2. Repeat the plotting steps from Part II.B above. This time, instead of opening a new plot 

window, re-open the plot from Part II to add a new curve. Rename the new data curve 

from "subtalar_angle_r" to "Soft AFO". Minimize the plot window. (Don't close, since 

we'll add another curve). 

C. Simulate and analyze a drop landing with a "stiff" AFO 

Now let's try making the AFO stiffer. You can edit the properties of the AFO using the OpenSim 

GUI's Property Editor. 

1. In the Navigator panel, go to Forces>Other Forces to find the AFO_med_bushing.  

2. Highlight the AFO_med_bushing by clicking on it once. You should now see the 

properties of the AFO_med_bushing in the Property Editor. 

3. Find the property in the list called translational_stiffness. This property controls the 

stiffness of the bushing that prevents the AFO cuff from translating with respect to the 

footplate on the medial side of the brace. 

4. Make the translational_stiffness 10 times stiffer in each direction (i.e., set the 

translational_stiffness property to 100000 100000 100000). 

5. Repeat steps 2–4 for AFO_lat_bushing. 

6. Repeat the simulation steps from Part II.A one more time. Rename/Save the new results as "StiffAFO" this 

time. 
7. Repeat the plotting steps from Part II.B. Once again, instead of opening a new plot window, re-open the 

plot from Part II to add a new curve. Rename the new data curve from "subtalar_angle_r" to "Stiff AFO". 

Questions 

1. You have now simulated three different drop-landing conditions: without an AFO, with a 

soft AFO, and with a stiffer AFO. What differences in peak ankle inversion do you 

observe between the simulations? 

2. Could this AFO mitigate ankle inversion injuries? 

IV. Advanced Design Challenge: Create an active orthotic 

Rehabilitation robotics are providing new active devices to help train and optimize movement. 

Orthotics for ankle injury prevention have traditionally been passive devices, but what if you 

could create an active mode for landing? We will add a torque motor at the ankle to model an 

active orthotic. Your challenge will be to optimize the timing and activation level of the active 

orthotic to prevent ankle inversion injury. 

A. Explore the AFO model 

1. Download the Active AFO files (linked at the top of the page) and add unzip the contents 

to your folder, [Example_Dir]\ToyDropLanding\ 

2. Select File>Open Model... navigate to the ToyDropLanding folder and select 

ToyLandingModel_activeAFO.osim. 
3. Explore the model using the Navigator panel. What new forces have been added? 



1. What degree of freedom does this motor control? 

2. What is the optimal force of this motor? 

B. Modify the active AFO torque profile 

The default setting for the active AFO is ‘off’ and you will need to define when the orthotic is 

active. To specify the torque produced by the active AFO and run a forward simulation, we will 

use the Forward Tool, which allows specification of additional settings: 

1. Select Tools>Forward Dynamics.... This launches the Forward Dynamics Tool. 

2. Under the Main Settings tab, find the Input subsection. 

3. Check the box for Solve for equilibrium for actuator states. This will initialize the 

tendon and muscle fibers before starting the integration. 

4. Set the Time range to process as 0 to 0.4. 

5. Change the output Directory by adding \ActiveAFO to the end of the displayed folder 

name. Depending on where you copied the example files, the location displayed should 

then be something like [Example_Dir]\ToyDropLanding\ActiveAFO. 

6. In the Input Subsection, select the folder button next to Controls. Open the 

file ActiveAFO_Controls.xml. 

7. Select the small pencil button next to the Controls box to edit this controls file. Under 

Select Excitations, check the box next to ActiveAFO and hit OK. This will open the 

Excitation Editor which shows the excitation of a controller (in our case, the activeAFO) 

with respect to time. 

8. Change the excitation profile by moving the points in the Excitation Editor. To select a 

point, hold down CTRL and click on the point (similarly you can select multiple points 

by holding down CTRL and dragging the mouse over multiple points).  To change the 

value of the points, you can either drag them on the screen, or enter a value in the “Set 

selected points to” box. You can also add or remove points. Click the “Help” button for 

more information. 

9. Once you are done editing the excitation profile, select Save As to save an xml file called 

ActiveAFO_Edited.xml. Close the Excitation Editor. 

10. On the Forward Dynamics set-up screen, make sure your edited Controls file is selected, 

by selecting the folder icon and choosing your new controls file.  

11. You can save your settings to re-use later by clicking on the Save... button and saving 

your settings (e.g. setup_forward_activeAFO.xml). 

12. Click Run. This will use the default options for all other settings. Since you haven't 

specified an Initial State file, the tool will use the current pose of the model in the GUI as 

the starting state for the simulation. 

13. The model will animate during the forward simulation. You can Close the tool after 

you've clicked Run. 

14. Once the simulation has completed, you can use the animation controls above the view 

window to view the motion. 

15. Rename the new motion to "ActiveAFO". The results will be automatically saved by the 

forward tool in the directory you specified above 

([Example_Dir]\ToyDropLanding\ActiveAFO). 



C. Design optimal AFO for drop landing 

Your challenge is to create the optimal AFO for drop landing. Edit the activation of the AFO and 

the stiffness to optimize your design. Your design will be judged on the following criteria: 

 Minimal AFO stiffness (for maximum comfort and low material costs) 

 Smallest torque required from the active AFO (for a small, compact motor) 

 Minimal amount of time the AFO is active (to maximize battery life) 

 Prevent ankle injury (inversion angle < 25°) 

Note that you must start your simulation from the same initial conditions and posture used in the 

previous sections (no reducing the size of the drop or starting posture). Your final design will be 

"judged" using the following information: AFO stiffness, torque profile of active AFO, amount 

of time AFO is active, maximum torque of active AFO, and maximum ankle inversion angle. 

V. Analyze the effects of muscle co-activation 

Individuals can modulate the stiffness of the ankle by co-activating muscles in anticipation of 

landing. Thus, co-contraction of muscles, especially the inverter and everter muscles, might reduce ankle 

inversion during landing. The model comes equipped with two controllers that set the level of excitation (control) of 

the inverter and everter muscles. These controllers are initially disabled in the model. By enabling them you can 

explore the effect of increased muscle co-activity on ankle inversion during the drop-landing. The co-activation 

controllers will operate in addition to the reflex controllers in the model. The reflex controllers, which you saw in 

action in the previous simulations, activate based on the stretch of the whole muscle–tendon unit. The level of 

excitation of the muscle is proportional (via a gain) to the rate that the whole muscle actuator is lengthening. 

A. Explore the model's controllers and simulate with co-activation 

1. If the original unassisted ToyLandingModel.osim is still loaded, make it current 

by right-clicking on the model name in the Navigator panel and choosing Make 

Current. Make sure your model is in the Default pose (Coordinates>Poses>Default). If 

you closed the model, re-load it using File>Open Model.... 

2. Go to the Navigator panel and find the list of the models Controllers.  

3. Locate the Reflexes controller. What is the current value of the controller gain? 

4. Find the co-activation controllers, R-inverter controls and R-everter controls. These 

controllers are disabled by default (i.e., the "isDisabled" property is true). 

5. These controllers activate the specified muscles at a prescribed constant value throughout 

the simulation.To see the prescribed control values, highlight R-inverter controls or R-

everter controls in the Navigator panel, then go to the Property Editor and click on the 

"..." button next to the "ControlFunctions" property. A tree view opens where you can 

navigate to the constants for each of the inverter or everter muscles in the model. 

6. Enable the R-inverter and R-everter controls by unchecking the "isDisabled" property in 

each of these model components.  

7. Run a forward simulation with the pre-activation controllers and add the results to your 

plot.  



Questions 

1. What is the constant control value for the inverters and everters when the co-activation 

controllers are enabled (see question 5 above)? 

2. Does co-activity of the inverters and everters mitigate ankle inversion injury? 

3. Optional: plot the muscle activations for the ankle inverters. How does the addition of the 

co-activation controller affect muscle activity? 

VI. Explore: Prevent injury with a device and training 

program 

In the sections above, you've explored how an AFO and muscle activation affect ankle inversion 

during landing. With the OpenSim simulation platform, there are many other scenarios and 

model properties that you can explore. For example, you can: 

 Add a backpack to the model (by adding a new body or increasing torso mass) 

 Change the initial pose of the model (e.g., increasing the initial ankle plantarflexion 

angle) 

 Explore different device designs by changing stiffnesses or creating a new device 

 Increase/decrease muscle strength to simulate training/disuse 

 Change control strategies by altering the reflex gains, changing the amount of co-

contraction, or adding new controllers 

 Explore kinematics and loading at the other joints in the model during landing 

 Test different landing scenarios (e.g., height, platform slope, surface characteristics) 

Design Challenge 

Apply what you've learned in the sections above to design an "optimal" device and training 

program to prevent ankle injury. You are free to modify any parameter of the model and the 

scenario, but keep in mind: 

 Increasing the AFO's stiffness will increase manufacturing costs and decrease comfort and performance 

versatility. 
 Training programs to increase muscle strength, improve co-activation strategy, improve landing position, 

etc. will also have costs. 
 A device and training program that works in a variety of scenarios is ideal. 
 Assume that a neutral ankle position (subtalar angle = 0) is ideal. 

Develop a combined device and training program. Use simulation and your knowledge of 

biomechanics to demonstrate that your proposed solution is optimal. 

Credits 

Matt DeMers, Ajay Seth, Jen Hicks, Jeff Reinbolt, Ajay Seth with input and testing help from 

many others 
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